OpenBSD 6.1 help with right click on touchpad


I am having problems getting my right click to work on a Lenovo T450s with a fresh install of OpenBSD 6.1

Current Setup and Notes

I am using a Lenovo T450s with XFCE 4. Nothing really special. If I switch to the default window manager right click works which to me says that quadrant of the touchpad is being recognized. Also if I enable tapping in the XFCE settings then use two fingers I get the events from what would be a right click. I have tried different settings with synclient and xinput however I have removed them all to start from scratch. At this point I am pretty much lost.

What is content of your " Section “InputClass” " /etc/X11/xorg.conf?

Got it working @bsdtux ?

sorry jaypatelani I have been swamped at work and haven’t had a chance to look at it. Let me do that when I get home tonight and I will post back

1 Like

@jaypatelani I didn’t see that file. I did have a 70-synaptics.conf file though that I can post

synclient tapbutton3=1
does this emulate right click under XFCE?

no dice on that. Tried to change it and got nothing

$ synclient | grep -i tap 
MaxTapTime              = 180
MaxTapMove              = 236
MaxDoubleTapTime        = 180
SingleTapTimeout        = 180
TapButton1              = 0
TapButton2              = 0
TapButton3              = 2
TapAndDragGesture       = 1


Here is my /usr/X11R6/share/X11/xorg.conf.d/70-synaptics.conf file

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
#       MatchDevicePath "/dev/input/event*"

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"

Put this configurations in /etc/X11/xorg.conf

`Section “InputClass”
Identifier “touchpad”
Driver “synaptics”
MatchIsTouchpad “on”
#Device “wsmouse”

Enable clickpad/multitouch support

Option “ClickPad” “true”

Middle-button emulation is not supported

Option “EmulateMidButtonTime” “0”

Define right soft button at the bottom

Option “SoftButtonAreas” “50% 0 82% 0 0 0 0 0”
Option “TapButton1” “1”
Option “TapButton2” “2”
Option “TapButton3” “3”
Option “VertEdgeScroll” “on”
Option “VertTwoFingerScroll” “on”
Option “HorizEdgeScroll” “on”
Option “HorizTwoFingerScroll” “on”
Option “CircularScrolling” “on”
Option “CircScrollTrigger” “2”
Option “EmulateTwoFingerMinZ” “40”
Option “EmulateTwoFingerMinW” “8”
Option “CoastingSpeed” “0”
Option “FingerLow” “35”
EndSection `

1 Like

That fixed it. I can now right click in XFCE. Now I need to figure out which one of those options fixed the issue.

1 Like

Option “TapButton3” “3”

This option is most probably reason for it.